Table of Contents

Glyphotext 1.0 User manual

Short tutorial: Exploration of a Glyphotext document

  1. Open the document Hatnub_gr14.got. You will find it in the examples directory of Glyphotext.
  2. First, take a look at the document properties, to see all the different meta-information that the documents carries. To display the Document Properties dialog, click on the Document Properties button which can be found in the right-hand section of Glyphotext (Document management).
  3. Now take a look at the page setting parameters of our document, accessible through the main menu under Options->Document Page Setup. Under the Hieroglyphs tabs, Line height is set to 0,80cm (0.31 inches). As for paper (thinking here of printing the text), under the Print Options tab, the type of paper selected is Lettre [ A4 ]. If that is not appropriate for you, you can choose here another size, US Letter for example (a usual format in America).
  4. Let's investigate the text itself. If, according to the resolution of your screen, the glyphs are too small (or too large), adjust the editor zoom factor. This adjustment is only effective when editing on-screen, and does not affect the metrics of the document itself (just as with MS Word). To adjust the zoom, select the desired value from the Zoom Dropdown button on the main toolbar, top-left, beside the button for the King List button).

    The 4 central editor windows (Hieroglyphs, LPDH, Transliteration and Translation) are resizable with respect to each other. Simply move the mouse over the separator between 2 of these windows and while holding down the left mouse button, move the mouse up or down to resize the windows. The Transliteration and Translation editors can even be hidden, by clicking the (X) on the top-right corner. This allows maximize eidtor space depending on the type of editing you are currently doing.

    After the Transliteration or Translation windows have been hidden, you can bring them back by seleting View->Transliteration and View->Translation from the main menu.

  5. A first look at the text reveals the presence of 3 numbering systems. Each one has its own functionality:
    • On the far left, in the grayed part (called the editor gutter), one finds the editor line numbers. These numbers are useful to find a specific area in the text, if one does not use any other numbering system (such as line numbers embedded in the text itself)..
    • There is a second margin (the margin of the text), which is part of the document. It is used to specify line numbers in the edited document. These numbers will be printed with the text and usually indicate the page number and the line number used in a typical edition of source texts (for example, Urk. IV 645,1 and following).

      Now create a new document and try out by ourself. Click on the . Note that the cursor is placed automatically where you must type the number for the line. You can type any text between the 2 quotes ("). You can, for a document, change the apparence of these numbers in the Document Page Setup dialog, accessible through Options->Document Page Setup from the main menu. Parameters related to text line numbers are grouped as Text line numbers, under the Hieroglyphs Tab.
    • As for the source line numbers (physical line numbers), we use a third numbering system which allows to insert the numbers into the hieroglyphic text (the cyan numbers in a rectangle in the figure on the right). The button to insert source line numbers looks like this: . Type some glyphs in your test document then insert a source line number. At anytime, you can modify the appearence of source line numbers under Options->Document Page setup, in the Source line numbers sub-section. Try different options to see the result.
  6. Let us have a look at the two main working windows: The hieroglyphs window and the LPDH editor. Click first on a quadrat in the hieroglyphs window: the entire quadrat you clicked is selected. If several the quadrat is made up of multiple glyphs and you wish to select only one of them, click on the desired glyph after the quadrat as a whole is already selected. Note that each time you select a quadrat or a particular glyph, its corresponding LPDH source code is also selected in the LPDH editor below: a direct way to find a precise position in the LPDH editor, in order to correct your document, to modify it, or else. The opposite is also true: if you move the caret in the LPDH editor, the corresponding glyph in the hiroglyphs window above it will be selected automatically.
  7. To modify a glyph: once a glyph is selected, you can apply modifiers to it to fine-tune its appearance, All glyph modifiers are located on the tabbed toolbar stack at the top of the application window. Make experiments with the various types of hatching, the mirroing, alignment, rotation, dimension, color. If you want to add a glyph at the selected location in your text, or correct your glyph by replacing it by another, you must replace and/or type the glyph code in the LPDH editor itself.
  8. To modify a sequence of glyphs in a given line, you can select contiguous sequences of hieroglyphs directly in the hieroglyphic window and then apply any desired modifications, such as creating a cartouche, serech, hout, hatching the selected quadrats or color then in red. To select a sequence of quadrats, you do as follows : click on the first desired quadrat, then holding down the Shift key, click on the last quadrat of the desired sequence. All quadrats in between those 2 clicked quadrats will be highlighted (selected).

It's all yours now !